Page 1 of 4 123 ... Last
  • Jump to page:
    #1
  1. Moderator From Beyond
    ASP Mastermind (5000+ posts)

    Join Date
    Sep 2004
    Location
    Israel
    Posts
    31,126
    Rep Power
    2921

    Post Setting Permissions to Access Database - step by step guide


    The following will solve those two common errors:
    ---
    Operation must use an updateable query
    cannot update database database is readonly
    ---
    Such errors occur when you try to update/delete/insert records
    to Access Database, but don't have proper permissions.
    Note, this is not IIS problem but rather Windows problem.
    Follow those steps, according to the Server OS:
    Window 2000 Professional/Windows 2000 Server
    1. Browse to the database file meaning the .MDB file by double
      clicking My Computer and browsing to the file.
    2. Right click the file.
    3. Choose Properties
    4. Go to the Security Tab
    5. Click the Add button
    6. Select IUSR_[computer name] and click Add
    7. Click OK
    8. Check the checkbox for Write permission in the Allow column
    9. Confirm.


    Window XP/Windows 2003 Server
    1. Browse to the database file meaning the .MDB file by double
      clicking My Computer and browsing to the file.
    2. Windows XP users:
      1. Go to Tools --> Folder Options
      2. Go to View tab
      3. Uncheck "Use simple file sharing" and confirm.
    3. Right click the file.
    4. Choose Properties
    5. Go to the Security Tab (XP users - if it won't show make sure
      you followed instructions in step #2)
    6. Click the Add button
    7. Type IUSR_[machine name] in the box, replace "machine name"
      with the name of the computer as you can see in the
      "From this location" textbox
    8. Click OK, check the checkbox for Write permission in Allow column.
    9. Confirm.


    That's all, you may have to repeat above steps to the folder
    containing the mdb file as well.

    Comments on this post

    • jmurrayhead agrees : :cheers: this was needed
    • baseballdude_ agrees : Excellent guide.
    • x07 agrees
    • user101 agrees : well done...perhaps it deserves a sticky..if not done so already
    • razaullah agrees : Gr8 Response with all details.
    • james.90 agrees : Great work.This solved my problem of a week weeks
    • new learner agrees : Thanks to Micky I found this pearl.
    • mercattor agrees : Outstanding Post, ShadowWizard!
    Last edited by Shadow Wizard; August 24th, 2010 at 02:53 AM.
  2. #2
  3. No Profile Picture
    Contributing User
    ASP Explorer (0 - 99 posts)

    Join Date
    Apr 2006
    Posts
    56
    Rep Power
    9
    Ur a star....i really needed this... Thanks

    Comments on this post

    • Shadow Wizard agrees : cheers dude, glad it helped! :)
  4. #3
  5. No Profile Picture
    Registered User
    ASP Explorer (0 - 99 posts)

    Join Date
    Jun 2005
    Posts
    10
    Rep Power
    0

    Thumbs up Highly recommended


    Thanks a mille.
  6. #4
  7. No Profile Picture
    Registered User
    ASP Explorer (0 - 99 posts)

    Join Date
    Jun 2006
    Posts
    15
    Rep Power
    0
    It solved my problem too.

    will the Uncheck "Use simple file sharing" change anything else in the way share files?
  8. #5
  9. Moderator From Beyond
    ASP Mastermind (5000+ posts)

    Join Date
    Sep 2004
    Location
    Israel
    Posts
    31,126
    Rep Power
    2921
    Originally Posted by lostside
    It solved my problem too.

    will the Uncheck "Use simple file sharing" change anything else in the way share files?
    as far as I know, it won't change anything else - only add the Security tab
    to the Properties window.
  10. #6
  11. No Profile Picture
    Contributing User
    ASP Discoverer (100 - 499 posts)

    Join Date
    Oct 2005
    Posts
    225
    Rep Power
    20
    Just set up new XP Pro - added IIS but no security tab! How do I add this.

    Thank you in advance
  12. #7
  13. Moderator From Beyond
    ASP Mastermind (5000+ posts)

    Join Date
    Sep 2004
    Location
    Israel
    Posts
    31,126
    Rep Power
    2921
    Originally Posted by Phoenix_riser
    Just set up new XP Pro - added IIS but no security tab! How do I add this.

    Thank you in advance
    the Security tab has nothing to do with IIS..
    read the section "Window XP/Windows 2003 Server" and see step #2.
    it explain what you have to change in the Folder Options.
  14. #8
  15. No Profile Picture
    Registered User
    ASP Explorer (0 - 99 posts)

    Join Date
    Jul 2006
    Posts
    4
    Rep Power
    0
    we wish IIS can set folder write/read rights for every user, it is easy for us,I have meet this problem for serval times too.
    Last edited by Shadow Wizard; October 6th, 2006 at 06:39 AM. Reason: removed advertisement
  16. #9
  17. No Profile Picture
    Registered User
    ASP Explorer (0 - 99 posts)

    Join Date
    Nov 2006
    Posts
    2
    Rep Power
    0
    Thanks for sharing the useful information.
    This will help many new bees like me...

    Web Design Company | Delete history
  18. #10
  19. No Profile Picture
    Contributing User
    ASP Discoverer (100 - 499 posts)

    Join Date
    May 2006
    Location
    Delhi-India
    Posts
    231
    Rep Power
    30
    That s what I did, I could not even locate security Tab. May b I am very backward. Please help
  20. #11
  21. Moderator From Beyond
    ASP Mastermind (5000+ posts)

    Join Date
    Sep 2004
    Location
    Israel
    Posts
    31,126
    Rep Power
    2921
    in XP, this tab won't appear by default.
    refer to step #2:
    Go to Tools --> Folder Options
    Go to View tab
    Uncheck "Use simple file sharing" and confirm.
  22. #12
  23. No Profile Picture
    Contributing User
    ASP Explorer (0 - 99 posts)

    Join Date
    Feb 2007
    Location
    Penicuik, UK!!
    Posts
    31
    Rep Power
    8
    I can`t see the option from View:

    http://xs513.xs.to/xs513/07104/cantseeit.PNG
    Last edited by Shadow Wizard; September 24th, 2007 at 02:56 AM.
  24. #13
  25. Moderator From Beyond
    ASP Mastermind (5000+ posts)

    Join Date
    Sep 2004
    Location
    Israel
    Posts
    31,126
    Rep Power
    2921
    I think it's available only for XP professional edition.
    what OS you have?
  26. #14
  27. No Profile Picture
    Contributing User
    ASP Explorer (0 - 99 posts)

    Join Date
    Feb 2007
    Location
    Penicuik, UK!!
    Posts
    31
    Rep Power
    8
    Home.
  28. #15
  29. Moderator From Beyond
    ASP Mastermind (5000+ posts)

    Join Date
    Sep 2004
    Location
    Israel
    Posts
    31,126
    Rep Power
    2921
    Originally Posted by xxJanexx
    Home.
    so you can't install IIS and can't use ASP.. this guide is not relevant for you.
Page 1 of 4 123 ... Last
  • Jump to page:

Similar Threads

  1. Newbie question on access database.
    By XandarX in forum Visual Basic Programming
    Replies: 6
    Last Post: June 6th, 2005, 05:59 PM
  2. Same DB plays different with XP and W2K
    By datasurf in forum Microsoft Access Help
    Replies: 3
    Last Post: June 2nd, 2005, 11:41 PM
  3. How to access Remote Access Database using ASP.net
    By arvind2004 in forum .NET Development
    Replies: 1
    Last Post: October 3rd, 2004, 09:24 AM
  4. Access Database HELP...URGENT
    By bzibee in forum Microsoft Access Help
    Replies: 1
    Last Post: June 3rd, 2004, 11:25 AM
  5. problems with access database using DSN
    By saunaG in forum ASP Development
    Replies: 1
    Last Post: February 13th, 2004, 03:15 PM

IMN logo majestic logo threadwatch logo seochat tools logo