Hi All,

At the very outset I would like to state that this is my first ASP classic page that I have created which since the first deployment on IIS is giving me server 500 error. I have searched the entire web and have done almost everything possible to get this right, but all in vain.

I have created a classic ASP page using Web Matrix. This is a web based dashboard which connects to MSSQL server and fetch necessary information. I have a similar app in php which is working perfect, but I wanted to learn ASP hence was trying to make a similar web app on ASP. This app works absolutely fine onf Web Matrix. When I run this app from within web matrix (both on chrome as well as IE) it connects to the required database and I can browse the details as expected. The problem starts when I host this on IIS (localhost on my windows 7 pc). This is the exact procedure that I have followed :

1) Created a new Site on IIS named "YCube" 2) Using basic settings I have given the following Physical path for the app (D:\YVXS\Personal\ASP\SSTool\Ycube) {the project output folder} 3) In the bindings page I have assigned port 81 4)IIS authentication is set to "Anonymous Auth" 5) Application pool for asp is set to classic (as IIS first stated it cannot perform the task in integrated mode)

After this when I tried browsing localhost:81/menu.asp, it given me server 500 error. The 21 days research starts now (bullet points below)

1) To get the descreptive errors on the web page I did following but the error description did not change IIS->asp->Compliation->send error to browser =true, friendly http error on IE = disabled

2) IIS log files, not sure if iam not able to understand the error but am getting follwing on the log file (C:\inetpub\logs\LogFiles\W3SVC1

2013-02-23 08:07:44 ::1 GET /menu.asp |-|ASP_0147|500_Server_Error 80 - ::1

3) On the IIS forum only I underatood at time global.asa file can cause this problem, I deleted this file and tried, all in vain

4) The folder and files permission for my site is read only, however I have tried the same with read and write access also, this also did not help

5) On the error pages in IIS, i have changed the "Edit feature settins" to "Detailed error", this also didnot give me any futher error desc.

6) 24 times i have uninstalled IIS and installed back, nothing has happend

7) Someone suggested to created a dummy asp file and try hosting the same of IIS, so I used a small code ("[

<HTML>
<BODY>
This page was last refreshed on <%= Now() %>.
</BODY>
</HTML>"], this is giving correct output (This page was last refreshed at 18:88:22....), however with my original asp page I still get server 500 error

8) A friend of mine suggested to delete all other hosted web pages from IIS and try (I had one PHP on the IIS), hence I deleted the same and tried, no changes at all

9) Event log file is showing nothing pertaining the ASP (only few files are there which tells about unexpected shutdown of my PC)

10) I created a second ASP file which had MS access at the backed, this only is also giving me same server 500 error

11) Other things that I have tried is changing the web.config file to send detailed error, (thouh i forgot the exact line) but that also did not help me

Here are my system config and other details Windows 7 professional, IIS7.5.7600, MSSQLR2express. Also please note that I have tried hosting this on two othe pc's that I have(both windows 7) and in office server 2003, but all are giving me same server 500 error.

Never thought learning a classic asp will put me into all this Jazz...please help..

Regards,

Youbaraj Sharma