#16
  1. No Profile Picture
    Registered User
    ASP Explorer (0 - 99 posts)

    Join Date
    Nov 2007
    Posts
    20
    Rep Power
    0

    Great tip and help!


    I just read your post and it has some great information in it.
    But I have server 2003 web system and It didn't show the
    (Use simple file sharing) in the view tab. It wasn't there to uncheck. I got the error, can not update database it is read only and have checked every permission 3 or 4 times and still get this error. Does the server 2003 suppose to have the file,
    Use simple file sharing??
    Thanks for your help!
    Last edited by Shadow Wizard; December 3rd, 2007 at 11:03 AM.
  2. #17
  3. Moderator From Beyond
    ASP Mastermind (5000+ posts)

    Join Date
    Sep 2004
    Location
    Israel
    Posts
    31,135
    Rep Power
    2925
    Win2K Server should always have the Security tab, XP is the
    only one hiding it as far as I know.
    you don't have Security tab?
  4. #18
  5. No Profile Picture
    Registered User
    ASP Explorer (0 - 99 posts)

    Join Date
    Nov 2007
    Posts
    20
    Rep Power
    0

    No, don't see it


    Originally Posted by Shadow Wizard
    Win2K Server should always have the Security tab, XP is the
    only one hiding it as far as I know.
    you don't have Security tab?
    I have the server 2003 Web Edition. I followed your instructions and opened up c:inetpub/wwwroot and the folder, then clicked on tools, folder options. then the view tab and read every option it had, but it is no, use simple file sharing option on my server to uncheck.
    I ran across this error yesterday about, can not update database for it is read only. I spent hours checking every permission posible with no success. I even created a new access database and used that yesterday and this morning I went to update and got the same error again of can not update database because it is read only. I used the IIS to set permissions, used windows explorer to check and set permissions with no luck. Opened the database itself and checked permissions. but still get that error.
    It's got me confussed!
    I have no idea what else to check.
    and thanks for your reply!
    We appreciate it sir.
  6. #19
  7. No Profile Picture
    Moderator
    ASP Mastermind (5000+ posts)

    Join Date
    Feb 2004
    Location
    Virginia, USA
    Posts
    13,248
    Rep Power
    1911
    Simple File Sharing is not an option in server edition, as Shadow stated. The Security tab should already be visible. Right-click the folder, click the Security tab and adjust permissions from there.
    Check out my stream on Twitch!
  8. #20
  9. Moderator From Beyond
    ASP Mastermind (5000+ posts)

    Join Date
    Sep 2004
    Location
    Israel
    Posts
    31,135
    Rep Power
    2925
    Originally Posted by vettman
    I have the server 2003 Web Edition. I followed your instructions and opened up c:inetpub/wwwroot and the folder, then clicked on tools, folder options. then the view tab and read every option it had, but it is no, use simple file sharing option on my server to uncheck.
    I ran across this error yesterday about, can not update database for it is read only. I spent hours checking every permission posible with no success. I even created a new access database and used that yesterday and this morning I went to update and got the same error again of can not update database because it is read only. I used the IIS to set permissions, used windows explorer to check and set permissions with no luck. Opened the database itself and checked permissions. but still get that error.
    It's got me confussed!
    I have no idea what else to check.
    and thanks for your reply!
    We appreciate it sir.
    the Simple File Sharing step is not solving the issue.
    try to read my guide and try to understand what's
    going on.
    the vital step is giving permissions via Security Tab.
    if you don't see this tab you probably have restricted
    account yourself, and can't change server settings.
  10. #21
  11. No Profile Picture
    Registered User
    ASP Explorer (0 - 99 posts)

    Join Date
    Nov 2007
    Posts
    20
    Rep Power
    0

    Ok and thank you.


    Originally Posted by jmurrayhead
    Simple File Sharing is not an option in server edition, as Shadow stated. The Security tab should already be visible. Right-click the folder, click the Security tab and adjust permissions from there.
    I have allready been there and done that, but thank you for your help! We do appreciate it sir.
  12. #22
  13. Moderator From Beyond
    ASP Mastermind (5000+ posts)

    Join Date
    Sep 2004
    Location
    Israel
    Posts
    31,135
    Rep Power
    2925
    did you give permissions over the IUSR account over the folder and the file?
    did you give permissions to IWAM account?
    note that maybe IIS is running under different account: in such case give
    that account permissions.
    if you're using Integrated Windows Authentication you'll have to grant permissions
    to each user account in the network explicitly.
  14. #23
  15. No Profile Picture
    Contributing User
    ASP Explorer (0 - 99 posts)

    Join Date
    Mar 2007
    Posts
    68
    Rep Power
    12
    This is very nice tutorial, it is very helpful for begginers.THanks
  16. #24
  17. No Profile Picture
    Registered User
    ASP Explorer (0 - 99 posts)

    Join Date
    Jul 2008
    Posts
    2
    Rep Power
    0

    Issue with step 7


    First I want to mention that this is a very well made blog to help beginners like myself. With that said I can't get my computer to allow me to add a user from step 7. Every time I type in IUSR_GOLDFARB (which is the name of my computer) I get this message

    An object named "IUSR_GOLDFARB" cannot be found. Check the selected object types and location for accuracy and ensure that you typed the object name correctly, or remove this object from the selection.

    I cannot figure out what to do, please help me out.
  18. #25
  19. Moderator From Beyond
    ASP Mastermind (5000+ posts)

    Join Date
    Sep 2004
    Location
    Israel
    Posts
    31,135
    Rep Power
    2925
    Originally Posted by expressionweb08
    First I want to mention that this is a very well made blog to help beginners like myself. With that said I can't get my computer to allow me to add a user from step 7. Every time I type in IUSR_GOLDFARB (which is the name of my computer) I get this message

    An object named "IUSR_GOLDFARB" cannot be found. Check the selected object types and location for accuracy and ensure that you typed the object name correctly, or remove this object from the selection.

    I cannot figure out what to do, please help me out.
    make sure you have IIS installed.. without IIS you won't have that account.
    if you have, click the Advanced button and then the Find Now button to
    get list of all possible accounts. look for Internet Guest account and add it.
  20. #26
  21. No Profile Picture
    Registered User
    ASP Explorer (0 - 99 posts)

    Join Date
    Jul 2008
    Posts
    2
    Rep Power
    0

    Thank you


    Originally Posted by Shadow Wizard
    make sure you have IIS installed.. without IIS you won't have that account.
    if you have, click the Advanced button and then the Find Now button to
    get list of all possible accounts. look for Internet Guest account and add it.
    Thank you for the quick response. You were right I didn't have the IIS installed. Is there any way to get this software or fix my database to be accessible online, without purchasing windows server 2003?
  22. #27
  23. Moderator From Beyond
    ASP Mastermind (5000+ posts)

    Join Date
    Sep 2004
    Location
    Israel
    Posts
    31,135
    Rep Power
    2925
    you need Windows CD and then you can add IIS from Control Panel --> Add/Remove programs. (Add/Remove Windows Components tab)
  24. #28
  25. No Profile Picture
    Registered User
    ASP Explorer (0 - 99 posts)

    Join Date
    Sep 2008
    Posts
    1
    Rep Power
    0
    thank you for the windows permissions info Shadow Wizard, muchly appreciated
  26. #29
  27. Moderator From Beyond
    ASP Mastermind (5000+ posts)

    Join Date
    Sep 2004
    Location
    Israel
    Posts
    31,135
    Rep Power
    2925
    Originally Posted by blad3runn69
    thank you for the windows permissions info Shadow Wizard, muchly appreciated
    no problem - glad it's useful and thanks for the kind words.
  28. #30
  29. No Profile Picture
    Registered User
    ASP Explorer (0 - 99 posts)

    Join Date
    Apr 2009
    Posts
    19
    Rep Power
    0

    what about users if they delete the source files.


    I have one question. i have developed a IIS / ASP/ Windows 2003 server based a small application in my office. Now i have given them Read / Write access on folder. but problem is this they can access these files easily and delete them too. how can i handle this situation to restrict them to delete file even i dont want to let them open the source files.

Similar Threads

  1. Newbie question on access database.
    By XandarX in forum Visual Basic Programming
    Replies: 6
    Last Post: June 6th, 2005, 05:59 PM
  2. Same DB plays different with XP and W2K
    By datasurf in forum Microsoft Access Help
    Replies: 3
    Last Post: June 2nd, 2005, 11:41 PM
  3. How to access Remote Access Database using ASP.net
    By arvind2004 in forum .NET Development
    Replies: 1
    Last Post: October 3rd, 2004, 09:24 AM
  4. Access Database HELP...URGENT
    By bzibee in forum Microsoft Access Help
    Replies: 1
    Last Post: June 3rd, 2004, 11:25 AM
  5. problems with access database using DSN
    By saunaG in forum ASP Development
    Replies: 1
    Last Post: February 13th, 2004, 03:15 PM

IMN logo majestic logo threadwatch logo seochat tools logo